當前位置:網站首頁>version `ZLIB_1.2.9‘ not found (required by /lib64/libpng16.so.16)

version `ZLIB_1.2.9‘ not found (required by /lib64/libpng16.so.16)

2022-06-24 00:35:23enjoy囂士

背景

今天遇到個線上問題
環境centos7.9, openjdk 1.8, easyexcel 3.0.5

報錯顯示初始化錯誤 Could not initialize class sun.awt.X11FontManager
按照這個解决 鏈接

之後又報錯 version ZLIB_1.2.9 not found (required by /lib64/libpng16.so.16)

linux軟甲版本不兼容,需要手動下載安裝zlib1.2.9

方法

wget https://www.zlib.net/fossils/zlib-1.2.9.tar.gz

tar -xvf zlib-1.2.9.tar.gz
cd zlib-1.2.9
./configure
sudo make
sudo make install

大坑…

版權聲明
本文為[enjoy囂士]所創,轉載請帶上原文鏈接,感謝
https://cht.chowdera.com/2022/175/202206232253439099.html

隨機推薦